web app as service file access in a documents folder

  1. 2 weeks ago

    Markus R

    Jan 12 Pre-Release Testers, Xojo Pro Europe / Germany
    Edited 2 weeks ago

    hello, i have a web app and registered it as service on a windows 2016 server standard.
    now i like to open & read a file from a users documents folder at web app start.
    what windows file permissions i must add that the app have access there?
    seems a service run with special security settings and can not open the file.

    @Markus R hello, i have a web app and registered it as service on a windows 2016 server standard.
    now i like to open & read a file from a users documents folder at web app start.
    what windows file permissions i must add that the app have access there?
    seems a service run with special security settings and can not open the file.

    You’ll need to run the service as the user you want to access.

  2. Wayne G

    Jan 12 Pre-Release Testers, Xojo Pro, MVP Auckland, New Zealand

    What path are you using to access the file? I'm not seeing the issue here, but I'm testing on Windows 10.

  3. Greg O

    Jan 12 Xojo Inc Answer scout.galaxy.barn

    @Markus R hello, i have a web app and registered it as service on a windows 2016 server standard.
    now i like to open & read a file from a users documents folder at web app start.
    what windows file permissions i must add that the app have access there?
    seems a service run with special security settings and can not open the file.

    You’ll need to run the service as the user you want to access.

  4. Markus R

    Jan 12 Pre-Release Testers, Xojo Pro Europe / Germany
    Edited 2 weeks ago

    @Wayne G What path are you using to access the file? I'm not seeing the issue here, but I'm testing on Windows 10.

    just
    C:\Users\MyUser\Documents\List.txt

  5. Markus R

    Jan 12 Pre-Release Testers, Xojo Pro Europe / Germany

    @Greg OLone You’ll need to run the service as the user you want to access.

    ok, i will do so.

or Sign Up to reply!