Open Event and LoadURL - Please help

  1. 4 weeks ago

    I have a canvas thats being used as a button with a MouseUp event : HTMLViewer1.LoadURL("http://somerandomlink.com/view.php")

    It no longer works.

    I also have a HTMLViewer with an OPEN event that pre-loads: HTMLViewer1.LoadURL("http://somerandomlink.com/view.php")

    It no longer works either.

    How do I get a url to load from an EVENT if OPEN doesn't work anymore or the LoadURL?

    Help please my app is broken...

    macOS and Windows - desktop application

  2. Horst J

    Nov 19 Pre-Release Testers, Xojo Pro Europe, Germany, Stuttgart

    try "https:"

  3. internal server... no https only http

  4. Horst J

    Nov 19 Pre-Release Testers, Xojo Pro Europe, Germany, Stuttgart

    Please use "https" and it works.

  5. ok i have:
    HTMLViewer1
    with the event OPEN
    and this HTMLViewer1.LoadURL("http://rcp-app01.rcpmarketing.net/PW/_rcp_creative/view.php")
    in the editor

    neither: HTMLViewer1.LoadURL("http://rcp-app01.rcpmarketing.net/PW/_rcp_creative/view.php")
    or HTMLViewer1.LoadURL("https://rcp-app01.rcpmarketing.net/PW/_rcp_creative/view.php")

    seem to work as OPEN as an EVENT seems to be depreciated?
    macOS Mojave - displaying as webkit

  6. 3 weeks ago

    Dave S

    Nov 19 San Diego, California USA

    its not a valid URL... I just tried it, and Safari said... Sorry....

  7. Michael D

    Nov 19 Pre-Release Testers, Xojo Pro

    Your name server says this is a https://en.wikipedia.org/wiki/Private_network
    Private network (all 10.x.x.x IP addressses are LAN only)

    dig rcp-app01.rcpmarketing.net
    ; <<>> DiG 9.10.6 <<>> rcp-app01.rcpmarketing.net
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3820
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 8192
    ;; QUESTION SECTION:
    ;rcp-app01.rcpmarketing.net.	IN	A
    
    ;; ANSWER SECTION:
    rcp-app01.rcpmarketing.net. 7129 IN	A	10.254.253.63

    That's only going to be accessiable from your LAN, not from a WAN

  8. Horst J

    Nov 19 Pre-Release Testers, Xojo Pro Europe, Germany, Stuttgart

    If you have setup your home router, you can open your own local URLs.
    Example:
    ShowURL("http://fritz.box") => my own DSL router
    ShowURL("http://192.168.168.28") => my own NAS

    And also https
    ShowURL("https://fritz.box") => my own DSL router
    ShowURL("https://192.168.168.28") => my own NAS

    If you use the IP address, it works without special routing on your LAN.

  9. Edited 3 weeks ago

    I know - It's an internal app.. purposely not accessible to the outside world...

    I've used and built this app since 2016... updates I added worked in the 2018 version..

    my current version works just fine...

    however in when I build this in XOJO 2019 release 2 version this will not work..

    There is NO ssl on the domain... does the HTMLViewer now require an SSL to view content? If I type the URL into chrome it works, AND if I type

    HTMLViewer1.LoadURL("https://apple.com") this works?

    It's just a domain without and SSL. - I've tried the domain with both http AND https.. nothing works.

    -image-
    -image-

  10. Tanner L

    is not verified Nov 20 Pre-Release Testers to.on.ca

    Might be worth looking into NSAppTransportSecurity. Some threads:

    https://forum.xojo.com/52081-info-plist-in-serviceapplication/0
    https://forum.xojo.com/51934-app-transport-security/0

    and a blog:

    https://blog.xojo.com/2018/12/14/app-transport-security-on-macos/

  11. Michel B

    Nov 20 Pre-Release Testers, Xojo Pro

    If a regular browser can open that URL, and not htmlViewer, it may have to do with userAgent.

    Try setting the user agent to the same as the browser.

    See https://www.whoishostingthis.com/tools/user-agent/

  12. Jason K

    Nov 20 Pre-Release Testers

    @Wally D I know - It's an internal app.. purposely not accessible to the outside world...

    I've used and built this app since 2016... updates I added worked in the 2018 version..

    my current version works just fine...

    however in when I build this in XOJO 2019 release 2 version this will not work..

    There is NO ssl on the domain... does the HTMLViewer now require an SSL to view content? If I type the URL into chrome it works, AND if I type

    HTMLViewer1.LoadURL("https://apple.com") this works?

    It's just a domain without and SSL. - I've tried the domain with both http AND https.. nothing works.

    -image-
    -image-

    Are you using 2019r2.1? It was just released and might fix that deprecation message. Try that

  13. if I open my project in 2019 r2 and compile it.. HTMLViewer will not open a NON https URL...

    If I open the project in 2018 r3 - which was the last time I built this.. it works just fine.

    Not sure... maybe a bug..

  14. Anthony C

    Nov 21 Pre-Release Testers, Xojo Pro, Third Party Store GraffitiSuite Developer

    @Wally D
    If on macOS: https://docs.xojo.com/UserGuide:App_Transport_Security

  15. Emile S

    Nov 21 Europe (France, Strasbourg)

    Trying old version will not help/

    Use 19r2.1… (since you can do that).

or Sign Up to reply!