A stupid question about cubeSQL

  1. last week

    Simon B

    Oct 8 Europe (Wiltshire, UK)

    I have a cubeSQL database file running on my localhost, standard port.

    I am having huge problems connecting to this database from my laptop using the same internet connection as my main machine (same wi-fi connection).

    How do I log on to the cubeSQL database from my laptop? What host and port do I put in my client side program?

    Simon.

    I found it!

    All the above replies pushed me to the correct IP Address.

    Thanks to all.

    Simon.

  2. brian f

    Oct 8 Pre-Release Testers, Xojo Pro Chilly California

    You can use the IP of the machine hosting CubeSQL and the default port is 4430

  3. brian f

    Oct 8 Pre-Release Testers, Xojo Pro Chilly California

    This is what I have in my program to connect:

    //Setting up connection to the Database
    CubeDB = New CubeSQLServer

    //For CubeSQL connection
    CubeDB.Host = "IP ADDRESS"
    CubeDB.Port = 4430
    CubeDB.DatabaseName = "DB NAME" //Database name to connect to
    CubeDB.UserName = "Username Here"
    CubeDB.Password = "Password Here"

  4. Jay M

    Oct 8 Pre-Release Testers, Xojo Pro NC, USA

    The host machine has to be reachable from the remote machine (some wi-fi setups don't allow this, like at a public place). And the host machine's firewall has to allow connections to that port.

  5. Simon B

    Oct 8 Europe (Wiltshire, UK)

    @brian f This is what I have in my program to connect:

    //Setting up connection to the Database
    CubeDB = New CubeSQLServer

    //For CubeSQL connection
    CubeDB.Host = "IP ADDRESS"
    CubeDB.Port = 4430
    CubeDB.DatabaseName = "DB NAME" //Database name to connect to
    CubeDB.UserName = "Username Here"
    CubeDB.Password = "Password Here"

    Yes, I have the same connections (with the right data, of course!

    @Jay M The host machine has to be reachable from the remote machine (some wi-fi setups don't allow this, like at a public place). And the host machine's firewall has to allow connections to that port.

    My firewall is currently turned off, allowing all connections.

    It is possible that this is a router issue - how do I check this?

  6. Simon B

    Oct 8 Answer Europe (Wiltshire, UK)

    I found it!

    All the above replies pushed me to the correct IP Address.

    Thanks to all.

    Simon.

or Sign Up to reply!