VirtualHostX

  1. 8 weeks ago

    James D

    Sep 18 Pre-Release Testers, Xojo Pro Europe (Switzerland)

    Has anyone used VirtualHostX to test CGI applications locally on the Mac?

    I just started exploring it this morning and would well opinions on it.

  2. Olivier C

    Sep 18 Pre-Release Testers, Xojo Pro Europe (Belgium, France)
    Edited 8 weeks ago

    I downloaded it after seeing your post.
    Couldn’t manage to start it, errors arise. It seems the VirtualBox can’t start.
    No much help on documentation side. I’ll ask their support and see ...

    Not sure it’s better than setting up a MAMP.

    Did you get some success running Xojo cgi apps ?

  3. James D

    Sep 19 Pre-Release Testers, Xojo Pro Europe (Switzerland)

    Hi there,

    I had no problem installing it and getting a couple of PHP pages running, but that’s it so far.

    The documentation leaves a lot to be desired. I have not figured out how to get the CGI working, turn on debugging for PHP and install Ruby.

  4. James D

    Sep 20 Pre-Release Testers, Xojo Pro Europe (Switzerland)

    Just to complete this:

    • Yes I got the CGI working, just follow the FAQ on running CGI apps
    • Yes I got the PHP debugging working, you just need to follow the standard instructions to install XDebug
    • Yes I got Ruby up and running, again just follow standard install routines.

    Over all, this utility does not do anything that you could not do just using virtual box and vagrant. However it does make it much easier to run multiple sites, so I'd say it's worth the money.

  5. Olivier C

    Sep 20 Pre-Release Testers, Xojo Pro Europe (Belgium, France)

    Hi James,

    Good for you ;-)
    I’ve got answers from VirtualHostX, saying it happens « sometimes » and providing a way to re-install.
    No more chances, failing to install VirualBox, multiple times.
    What’s strange is that VirtualBox is already installed on my Mac and works fine ...

    I stop trying.

    Cheers

  6. James D

    Sep 20 Pre-Release Testers, Xojo Pro Europe (Switzerland)

    Hi Olivier,

    I did not have either VirtualBox or Vagrant installed. Probably more likely to work.

    James

or Sign Up to reply!