intermittent Build failed on win 7 -- no error messages .

  1. 3 months ago

    Luigi F

    Jul 11 Pre-Release Testers, Xojo Pro

    Ok I see that this topic has been asked a bunch of times in
    the past -- but what I do not see is any definitive answers to
    the problem:

    I am developing code in a win 7 box. I make my changes, and
    then I hit the green run button. Sometimes, after my code runs
    (yes I do exit the running code gracefully) the next time I hit
    the green "run" button on Xojo I get a very brief popup that says
    "build failed" (Xojo 2019r1 by the way) and the code fails to run.

    Exiting the IDE completely, and re-starting --sometimes-- fixes the
    issue. Sometimes not. Sometimes it just takes a few minutes of time,
    and then it works the next time. I check task manager, and it
    doesn't --look-- line anything is left running (but who knows, there are
    hundreds of tasks always waiting cpu tie in win 7)

    What am I missing folks? Why am I getting into this incredibly
    frustrating situation? How do I quickly fix it when it happens?
    I this situation occurs if i taget win32 or win 64. I have not found
    any magic setting that fixes the issue.

    Thanks ,

    ----Lou

  2. Greg O

    Jul 11 Xojo Inc

    Check and see if your antivirus software is stopping the launch.

  3. Luigi F

    Jul 11 Pre-Release Testers, Xojo Pro

    its turned off.

  4. Dale A

    Jul 11 San Diego, California, USA

    I've seen this a few times, although not recently. In most cases I've noticed that it had left the Debug build folder behind when the IDE closed the app. I guessed that the system hadn't properly closed one of the library files so the next build failed trying to rebuild the library which the system had left behind. Once Windows gets around to closing it, things should be ok.

    Of course, that is only a guess based on my system so I could be wrong.

  5. Aditya N

    Jul 11 Pre-Release Testers, Xojo Pro
    Edited 3 months ago

    My last report about build failed is finally resolved by Xojo on 2019R2 Alpha, haven't encountered the mentioned issue but have you tried to delete the debug and build folder?, if it's locked by Xojo IDE or antivirus you could release the folders/files lock by iobit unlocker .

    Try to copy the error log from Xojo IDE into to here (right click in the error and copy). There is suppose to be more detailed info on how/what is failing from the copying the error log.

    What is your motherboard?, is there any chance you are in Intel Skylake platform? Does your hyper-threading is enabled in the Bios?

    [Edit]

    Just re-read that it has no error logged?, have you tried to run debug view and see if it has anything valuable?

  6. Luigi F

    Jul 16 Pre-Release Testers, Xojo Pro

    I cant right click in the error because it pops up and goes away real fast. The computer is an older lenovo Y560, but I would be dismayed if it was a chipset issue as every other freakin program runs fine. (Virtual box Vmware, linux, etc). I totally disabled windows defender, and I have no other anti-viri crap. This is driving me bat-S**T crazy. This has to be a solvable issue.. I am getting really disappointed with this IDE, as this is some basic stuff that should have been solved in alpha testing.. I can be the only xojo user out there using win7 and having this issue? What OS do most people using xojo use?

    I have tried targeting this for win32 and win 64 as both user and admin.. none of the advanced settings matter. The issue gets worse when I am debugging code, and I exit the code under debug. Please tell me that I did not spend hundreds of dollars on a useless language / IDE that is giving me "alpha" problems.. Sorry just frustrated out of my mind, knowing that my angry customer would be happy if I had just done this in VB6.

  7. Louis D

    Jul 16 Pre-Release Testers, Xojo Pro QC, Canada
    Edited 3 months ago

    have you tried to run debug view and see if it has anything valuable?

    +1
    You need to start debugview before the IDE to get any meaningful messages that would perhaps indicate an ide issue. More likely, it is something happening when you run your application, not necessarily linked to the IDE.

    For what it is worth, I develop on Windows (OK, Windows 10, not windows 7 ). No such error.

    Now, a few more questions:

    • is there anything in the Windows application logs? (management console, event viewer)
    • is the application folder on a network drive? (if so, try copying the app folder - the one that contains all your code - to a local drive. Try running from the local folder)
    • Is the application folder on a synchronized folder? (drop box or other similar) (if so, try to copy the folder to a "not synchronized" location. Sometimes, these services lock files and cause issues with running in the ide or building applications. There have been reports on the forum of issues when using synchronized folders. Try running from a non-synchronized folder.)

    edit: changes to improve clarity.

  8. Julian S

    Jul 16 Pre-Release Testers, Xojo Pro UK
    Edited 3 months ago

    Quick question, I don't suppose you are working on two separate projects at the same time, like a client and server? or working via network / vm shares?

  9. Luigi F

    Jul 16 Pre-Release Testers, Xojo Pro

    Sorry again for my visible frustration. I am only working on one project at a time -- not yet ambitious enough top start a second one ! how do I "start debugview before the IDE " ??

    Thanks

  10. Julian S

    Jul 16 Pre-Release Testers, Xojo Pro UK

    Before we get into debugview, see the images below (right click, open in new tab/window to make them bigger)

    • Click 1)
    • See the name in 2) this is the name you will looking for in 5) with Debug at the start
    • Make sure 3) is not checked or your list will be a LOT longer
    • Open task manager, Click 4) so your column is sorted so things don't jump around
    • See if 5) disappears when you close your app, see if you can run the project when this has gone, if you can't let us know. If this doesn't go for a long time after closing your app let us know.

    -image-

    -image-

or Sign Up to reply!