SegmentedControl: No focus after window is shown

  1. 2 months ago

    Thomas E

    Jun 12 Pre-Release Testers

    Hi!
    I did replace a custom BelvelButton with a custom SegmentedControl class (to support dark mode properly). It works fine but I have a small issue with the focus ring…

    The segmented control shows two segments with an icon (a flag for a language chooser). When a flag is clicked the chosen segments shows a focus ring and therefore it is obviously which language is active.

    But when the new window is opened there is no focus ring shown at all.
    I tried SegmentedControl.showFocus with no visible result. A SegmentedControlItem has no ".showFocus".

    What did I miss here?

    Xojo 2019r1.1 on macOS 10.14.5

    Using segmentedControlName.setfocus works here with the same setup as you. Tested with the "XojoNotesDesktop" example project. Add NoteCategory.SetFocus to the EditNoteWindow.Open event.

    The focus ring in dark mode is very faint, you have to look hard to see it. Also, you may need Full Keyboard Access turned on in System Preferences for this to work.

  2. Tanner L

    is not verified Jun 12 Pre-Release Testers Answer Toronto, Canada

    Using segmentedControlName.setfocus works here with the same setup as you. Tested with the "XojoNotesDesktop" example project. Add NoteCategory.SetFocus to the EditNoteWindow.Open event.

    The focus ring in dark mode is very faint, you have to look hard to see it. Also, you may need Full Keyboard Access turned on in System Preferences for this to work.

  3. Thomas E

    Jun 12 Pre-Release Testers

    My own fault… I guess I had not enough coffee in the morning.

    I did use "showFocus" instead of "SetFocus" which did of course not work. Now all is fine.

  4. Tanner L

    is not verified Jun 12 Pre-Release Testers Toronto, Canada

    @Thomas E I guess I had not enough coffee in the morning.

    3 cups minimum to get started...  

or Sign Up to reply!