iOS/Xcode/Xojo versions map

  1. 3 months ago

    Michael G

    May 8 Pre-Release Testers, Xojo Pro

    I have an app that must must target all iOS'es from 9.3.5 (iPad Retina+) on up, yet still be compatible with Apple Store requirements for current versions. Current app is targeted to iOS 9.3.5 with Xojo 2017r2.1/Xcode 7; want to update to 2019r1 and Xcode 10.2 but don't see a path to iOS 9.3.5 compatibility. What do I need to do to target basically everything? We have a slow-to-upgrade customer base.

  2. Michael G

    May 9 Pre-Release Testers, Xojo Pro

    Let me rephrase that - how can I target iOS9.3.5 using Xojo 2019r1 and Xcode 10.2?

  3. Jeremie L

    May 12 Pre-Release Testers, Xojo Pro, XDC Speakers Europe (France) - getpackr.io

    I am not sure that is possible with Xojo.

  4. Michael G

    May 24 Pre-Release Testers, Xojo Pro
    Edited 3 months ago

    I Installed the iOS 9.3 simulator in Xcode 10.2; available iDevices show up as both iOS 12.2 and 9.3 targets, and I was able to successfully build an app for iOS 9.3.

    When I invoke my project in Xojo 2019 r1.1, with the developer tools targeted at Xcode 10.2 (i.e. using xcode-select), the iOS 9.3 simulator targets do not appear as targets under iOS Debugging>Simulator Devices - just the 12.2 targets.

    I must target baseline iOS 9.3 devices as many of our customers use older devices (iPad Retina, for example), yet neither the Apple Store nor TestFlight accept apps for distribution other than those built with the Xcode 10.2 toolset.

    So, according to Xcode 10.2, iOS 9.3 simulator devices are available, but not available under Xojo. The iOS 9.3 devices *are* also available in the standalone simulator app. What's missing?

  5. Michael G

    May 25 Pre-Release Testers, Xojo Pro

    I have installed the iOS 9.3 simulators for Xcode 10.2. Can I build for iOS 9.3 using Xojo 2019r1.1 and Xcode 10.2? Yes or No?

  6. Greg O

    May 25 Xojo Inc

    Our minimum iOS supported target in 2018r4 and above is iOS 10.

or Sign Up to reply!