Raspberry applications don't work with new Xojo2019R1 and 2081R4

  1. 2 weeks ago

    Marco G

    Apr 11 Milan, Italy

    I have a big problem I cannot solve.
    I developed a very well working solution (on RP2 and RP3) on Xojo 2017 Release2 and 3. Application is serial data receiver, with GUI and data saving to server database.

    In December '18 I updated my test system (MAC OSX based) to Xojo 2018R4 and I compiled the same working project for RP3 (the same running fine the other solution made with previous Xojo version) but when I launch it, nothing happens.
    I believed I made a mistake and I tried many times, updated RP, changes Raspberry, SD, USB, etc... still the old working, but not the new one.
    No error, but nothing happens, no GUI, nothing.

    I just updated to Xojo2019R1(I have Pro license) and still nothing happens. Still like not working at all.

    What do I make wrong?
    Should I install something differently on RP to run the new packages 2018R4/2019R1 compared to 2017R3 version?
    I couldn't understand and still using the old Xojo2017, but why????

    I'm running late on projects as I cannot find out what's wrong.

    Thank you for any support or suggestion you could provide me

    I'm thinking of a missing library for such symptoms. like libunwind8 ?
    http://developer.xojo.com/system-requirements

  2. Jean-Yves P

    Apr 11 Pre-Release Testers, Xojo Pro Answer Europe (France, Besançon)

    I'm thinking of a missing library for such symptoms. like libunwind8 ?
    http://developer.xojo.com/system-requirements

  3. Javier M

    Apr 11 Pre-Release Testers, Xojo Pro AprendeXojo - Europe, Spain

    don't know if it can apply… but maybe you can take a look at the Linux Notes section in the System Requirements docs page to see if it may be related to some required library missing.

    Hope it helps and solves the problem

    Javier

  4. Marco G

    Apr 12 Milan, Italy

    Jean-Yves,
    you made my day!! Solved.
    I don't know how & why, but the libunwind8 library was not properly installed or updated..
    I restarted from zero, made a new install, reinstall the library and .... all working fine.

    Thank you so much

or Sign Up to reply!