Missing format option in "Make external" and "Export"

  1. 5 weeks ago

    Beatrix W

    Feb 19 Pre-Release Testers Europe (Germany)
    Edited 5 weeks ago

    My projects are in xml with external xml items. So I create a new class, add some code, click in the Navigator on "Make external", select xml instead of binary and save the new class.

    Until today.

    Yesterday I had major computer troubles. The iMac threw a hissy fit at the latest security update. I had to do a complete restore from TimeMachine. And now I have lost the format option in the Xojo dialog for "Make external" or "Export".

    -image-

    This happens in Xojo 2018r3 and r4. Everything works fine on my MacBook Air. How do I fix this?

    Looking near the top of the image there it seems that your xojo isnt licenced, probably due to the restore. This will cause the save screens to not show xml as an option. Try re-applying your licence using the Help>License Keys... menu after downloading the key from the website?

    EDIT

    You can download the licence by clicking this tiny image -image- to the right of the expiration date of your license.

  2. Jean-Yves P

    Feb 19 Pre-Release Testers, Xojo Pro Europe (France, Besançon)

    did you restore the entire time machine backup
    or reinstall a clean macos and migrate from the time machine backup at first run ?
    pretty sure you used the 1st method.
    then should try the second.
    good luck (and patience...)

  3. Beatrix W

    Feb 19 Pre-Release Testers Europe (Germany)

    Yes, I did the TimeMachine restore. No, I won't do a clean install because restoring from TimeMachine already took a whole day.

    The caches in Xojo are fresh, but it's not a compile problem anyways. I could fry the preferences with PrefsEditor.

  4. Julian S

    Feb 19 Pre-Release Testers, Xojo Pro Answer UK
    Edited 5 weeks ago

    Looking near the top of the image there it seems that your xojo isnt licenced, probably due to the restore. This will cause the save screens to not show xml as an option. Try re-applying your licence using the Help>License Keys... menu after downloading the key from the website?

    EDIT

    You can download the licence by clicking this tiny image -image- to the right of the expiration date of your license.

  5. Jean-Yves P

    Feb 19 Pre-Release Testers, Xojo Pro Europe (France, Besançon)

    ah yes Julian, it can be a licence problem ... good catch.

  6. Beatrix W

    Feb 19 Pre-Release Testers Europe (Germany)

    @Julian S : thanks, that was the problem.

or Sign Up to reply!