Web App and 2018r4

  1. 3 months ago

    Nedi F

    Jan 24 Pre-Release Testers, Xojo Pro Europe (Italy, Bologna)

    Hi, I have a couple of CGI Web App: these Apps, compiled with Xojo 2017r3, work fine. The same Apps (without any changes) compiled with Xojo 2018r4, don't run anymore.
    Error 500 Internal Server error.
    Server log: Thu, 24 Jan 2019 10:13:03 GMT [error] [client 93.34.116.39] - www.nedifreguglia.it - End of script output before headers: magmotsql.cgi, referer http://www.nedifreguglia.it/mengoli/

    What's wrong with Xojo 2018r4?

  2. Alberto D

    Jan 24 Pre-Release Testers

    Xojo 2018 needs libunwind8, that's the main difference. Can you check if your server has that (if it is a Linux server)?

  3. Nedi F

    Jan 24 Pre-Release Testers, Xojo Pro Europe (Italy, Bologna)

    Thank Alberto. No, I can't check it, but if my app doesn't work, I suppose it has not. Now I try to find the right answer to your question.
    Thank you: now at least I know what to search.

  4. 2 months ago

    Amy B

    Feb 5 Marietta, Georgia, USA.

    I suspect this is why none of my apps on ServerWarp are working rn. I've just submitted a trouble ticket.

    @Phillip Z not sure if you can assist on this or make a recommendation for any next steps?

    Not sure how libunwind8 req't would fit into my server plan?

    Thanks

  5. Ralph A

    Feb 5 Santa Monica, California

    @Amy B I suspect this is why none of my apps on ServerWarp are working rn. I've just submitted a trouble ticket.

    All my 2017r3 apps that have been converted with 2018r4 work fine on ServerWarp. So I doubt libunwind8 is the problem.

  6. Ralph A

    Feb 5 Santa Monica, California

    @Nedi F Hi, I have a couple of CGI Web App: these Apps, compiled with Xojo 2017r3, work fine. The same Apps (without any changes) compiled with Xojo 2018r4, don't run anymore.
    Error 500 Internal Server error.

    Did you make sure the 2017r3 app was not running when updating your files with the 2018r4 files? If it was running when you did that, you'll definitely get an Internal Server Error 500 when attempting to run the new app.

    Alternatively, did you make sure you uploaded all the newly built 2018r4 files (like the Libs and Resource files), not just the executable?

  7. Amy B

    Feb 5 Marietta, Georgia, USA.

    @Alberto D;Poo Xojo 2018 needs libunwind8, that's the main difference. Can you check if your server has that (if it is a Linux server)?

    I have opened a trouble ticket asking about this. I'll see what they have for an answer. Usually I get very good service so I'm not too worried.

  8. Amy B

    Feb 5 Marietta, Georgia, USA.

    @Ralph A Did you make sure the 2017r3 app was not running when updating your files with the 2018r4 files? If it was running when you did that, you'll definitely get an Internal Server Error 500 when attempting to run the new app.

    Alternatively, did you make sure you uploaded all the newly built 2018r4 files (like the Libs and Resource files), not just the executable?

    These are CGI apps... I might have to re-delete the directories as try uploading again.

    The main app had not been changed - it just... stopped working. So something server-side is what I suspect the issue to be.

  9. Amy B

    Feb 5 Marietta, Georgia, USA.

    @Ralph A All my 2017r3 apps that have been converted with 2018r4 work fine on ServerWarp. So I doubt libunwind8 is the problem.

    I used 2018r3 :/

  10. Ralph A

    Feb 5 Santa Monica, California

    @Amy B These are CGI apps... I might have to re-delete the directories as try uploading again.

    The main app had not been changed - it just... stopped working. So something server-side is what I suspect the issue to be.

    To make sure you can kill your existing app before upgrading it with new files, I suggest you read this:

    http://www.dev.1701software.com/blog/2013/09/08/upgrading-xojo-cgi-apps

  11. Amy B

    Feb 5 Marietta, Georgia, USA.

    @Ralph A To make sure you can kill your existing app before upgrading it with new files, I suggest you read this:

    http://www.dev.1701software.com/blog/2013/09/08/upgrading-xojo-cgi-apps

    That's the first thing I do with my web apps. I'll double-check my build while awaiting my ticket response.

  12. Ralph A

    Feb 5 Santa Monica, California

    @Amy B That's the first thing I do with my web apps. I'll double-check my build while awaiting my ticket response.

    So you tried killing the app that's not working by renaming the CGI file? And then you renamed it back again about 10 seconds later to see if it will now restart when attempting to hit it with a browser?

  13. Amy B

    Feb 5 Marietta, Georgia, USA.

    @Ralph A So you tried killing the app that's not working by renaming the CGI file? And then you renamed it back again about 10 seconds later to see if it will now restart when attempting to hit it with a browser?

    Nah. Deleted the files and waited a minute. Then re-uploaded it. Deleted the whole directory, in fact.

  14. Amy B

    Feb 5 Marietta, Georgia, USA.

    The whole directory was deleted. I've go to bed bc I've gotta be up in five hours at work. Blegh. So if y'all don't see further replies tonight, I'll be catching my z's.

  15. Nedi F

    Feb 6 Pre-Release Testers, Xojo Pro Europe (Italy, Bologna)
    Edited 2 months ago

    Well. The CGI web app built with Xojo 2017r3 run fine. When I re-build them with Xojo 2018r4 no one of them works, and the problem is that the server doesn't find the library libunwind8 (the server error log says "error while loading shared libraries: libunwind.so.8" )
    The solution is to copy the libraries libunwind.so.8 and libunwind-x86_64.so.8 into the Libs folder: this way the CGI Webb Applications built with Xojo 2018r4 work fine.
    (Antonio Rinaldi gave me the answer).

  16. Antonio R

    Feb 6 Pre-Release Testers, Xojo Pro Europe (Italy)

    Yes, and as I told to Nedi, you can use a simple copy step for Linux to add them at compile time.

    In these cases, always look at the server log. You can get the right hint.

  17. Ralph A

    Feb 6 Santa Monica, California

    @Nedi F Well. The CGI web app built with Xojo 2017r3 run fine. When I re-build them with Xojo 2018r4 no one of them works, and the problem is that the server doesn't find the library libunwind8 (the server error log says "error while loading shared libraries: libunwind.so.8" )
    The solution is to copy the libraries libunwind.so.8 and libunwind-x86_64.so.8 into the Libs folder: this way the CGI Webb Applications built with Xojo 2018r4 work fine.
    (Antonio Rinaldi gave me the answer).

    That's a great idea. This way you can solve this problem even when you don't have access to that part of your server, as in managed server situations.

  18. Phillip Z

    Feb 6 Pre-Release Testers, Xojo Pro Florence, SC

    I'll take a look Amy. One thing to note is deleting the directory does not actually kill the process.

  19. Ralph A

    Feb 6 Santa Monica, California

    @Phillip Z I'll take a look Amy. One thing to note is deleting the directory does not actually kill the process.

    She could upload it to a new directory and make sure its App Identifier is different.

  20. Antonio R

    Feb 6 Pre-Release Testers, Xojo Pro Europe (Italy)

    The best way to update the app is to create a special url that will quit the app.
    Every online user will reload it automatically (restart) and will load the new version

    Obviously to avoid unauthorised call is better to check for something (IE a file) that you can upload with the update and remove before quitting.

  21. Newer ›

or Sign Up to reply!