Assertion failed file /Users/joe/mclinker ?

  1. 8 months ago
  2. Tim J

    30 Dec 2018 Pre-Release Testers, Xojo Pro Dehydrating in AZ

    That error path is from Joe's system.

    Have you made sure that the "Builds -" folder is empty?

  3. Michael D

    30 Dec 2018 Pre-Release Testers, Xojo Pro

    It's funny when information from one person's build system leaks like this - I once had a coworker who named his hard drive "Sh*tHead" which occasionally led to some interesting bug reports :-)

  4. Beatrix W

    31 Dec 2018 Pre-Release Testers Europe (Germany)

    That looks like something from "mclinker". See https://github.com/mclinker/mclinker .

    The Valentina folks use something called "Jenkins". I thought for years that this was a name.

  5. Andrew L

    2 Jan 2019 San Francisco, CA, USA

    Could it be @Joe R?

  6. 6 months ago
  7. Greg O

    Feb 25 Xojo Inc

    Have you tried all three compiler optimization levels?

  8. Greg O

    Feb 25 Xojo Inc

    Do you get this compile error on an empty project?

  9. Ulrich B

    Feb 26 Pre-Release Testers, Xojo Pro Europe (Germany, Berlin) · xo...

    @Andrew L Could it be @Joe R?

    It very probably is. But he was not seen here for over a year, so I guess he will not answer.

  10. Greg O

    Feb 26 Xojo Inc

    @Ulrich B It very probably is. But he was not seen here for over a year, so I guess he will not answer.

    Joe originally compiled the linked on his workstation that’s where that comes from.

  11. Greg O

    Feb 26 Xojo Inc

    @dave d Yes and one with a single button saying hello world.

    Ok, instead of double clicking the ide to start it, open a terminal window, type open , drop the Xojo.app bundle into the terminal window and press return. The ide will launch and spew a bunch of console messages. Once the ide launches, go to the terminal window and press CMD-K to clear the window. Now create a web project and compile it for Linux ARM. I’m curious if you get any errors there.

  12. Jason P

    Mar 1 Xojo Inc Texas

    What plugins have you got installed and is this app trying to use any of them? Maybe they have no ARM 32 bit portions?

  13. Newer ›

or Sign Up to reply!