Cant Run CGI in vps

  1. 9 months ago

    Novasof S

    15 Dec 2018 Pre-Release Testers, Xojo Pro

    we have many app running in vps like hostgator and others
    but we are try to deploy in a new customer vps host at arvixe
    we make a simple web app to tray also we used the cgi xojo sample for test
    but we cant run any cgi app with xojo, we tray a simple helloworld write cgi just with code and run perfectly
    some body know similar issues.

    The server is linux x86
    the pearl path is /usr/bin/perl
    we compiled with xojo 2018r4
    the error is 500 internal server error
    we change the port an check for the ports an work fine
    also we check the files property is in 755 and 666
    the proble is just with xojo cgi, other cgi is work
    tks

  2. Derk J

    15 Dec 2018 Pre-Release Testers, Xojo Pro

    You might need libunwind8 and can try "ldd /path/to/your/app" to check for missing libraries.

  3. Novasof S

    15 Dec 2018 Pre-Release Testers, Xojo Pro

    tks for your reply Derk but i have access just to cpanel i dont know if can make ldd command from cpanel i will ask to host people

  4. Derk J

    15 Dec 2018 Pre-Release Testers, Xojo Pro

    Also set the execute permissions for the executable and libraries

  5. 8 months ago

    Nedi F

    24 Jan 2019 Pre-Release Testers, Xojo Pro Europe (Italy, Bologna)
    Edited 8 months ago

    @Novasof Snbsp;Roddney Colman The server is linux x86
    the pearl path is /usr/bin/perl
    we compiled with xojo 2018r4
    the error is 500 internal server error
    we change the port an check for the ports an work fine
    also we check the files property is in 755 and 666
    the proble is just with xojo cgi, other cgi is work
    tks

    Hi, have you solved your problem? I am having the same issue: a CGI app compiled with Xojo 2018r4 does’nt work; the same app compiled with Xojo 2017r3 works fine.

  6. Ralph A

    24 Jan 2019 Santa Monica, California

    If you're running both cgi apps at the same time then they must have different app identifiers. Otherwise you will get this error.

or Sign Up to reply!