2018r4 IDE very slow

  1. 6 weeks ago

    Darren R

    Dec 12 Pre-Release Testers, Xojo Pro

    The IDE has been getting slower with each release. The 2018r4 release borders on not usable. I have a very large app but still.... Anyone else experiencing this?

    MacPro, 6 core, 64GB, 1TB SSD, MacOS Mojave.

  2. Dave S

    Dec 12 San Diego, California USA

    I had read other topics where people complained of this... and I had not really seen it myself.... until now.
    and I have a top end iMac

  3. Jean-Yves P

    Dec 12 Pre-Release Testers, Xojo Pro Europe (France, Besançon)

    @Dave S I had read other topics where people complained of this... and I had not really seen it myself.... until now. and I have a top end iMac

    what did you change in your configuration to have this appear ? only update to r4 ?

  4. Sascha S

    Dec 13 Pre-Release Testers, Xojo Pro Germany

    Since the last FC and now the release, i have to wait 1-2 MINUTES when i quit the Debugging App until Xojo responds again.

    MacBook Pro 2017 (15 inch) with macOS Mojave. Happens on internal Retina Screen and on external Ultra-Wide Monitor.

  5. Beatrix W

    Dec 13 Pre-Release Testers Europe (Germany)

    Has anyone done a sample in the ActivityViewer when Xojo is not responding?

  6. Dave S

    Dec 13 San Diego, California USA

    @Jean-YvesPochez only update to r4 ?

  7. Ralph A

    Dec 13 Santa Monica, California
    Edited 6 weeks ago

    I Just tested 2018r4 and do notice any of these slowness issues. The two projects I tested are only 18 mb or less in sized, however.

    Running on a Macbook Pro 2015 High Sierra. 16mb RAM.

  8. Sascha S

    Dec 13 Pre-Release Testers, Xojo Pro Germany

    @Ralph A Running on a Macbook Pro 2015 High Sierra. 16mb RAM.

    With only 16mb of RAM, this IS impressive!

  9. Ralph A

    Dec 13 Santa Monica, California

    @SaschaSchneppmueller With only 16mb of RAM, this IS impressive!

    Yep. That's why I posted the RAM here.

  10. Dave S

    Dec 13 San Diego, California USA

    Ralph... I believe you meant 16GIG not MEG

  11. Ralph A

    Dec 13 Santa Monica, California

    Oy. Yes. 16gb.

  12. Roger C

    Dec 13 Lewis Center, OH

    I Just tested 2018r4 and do notice any of these slowness issues

    ???
    Did you mean "do NOT notice"? If so, that would coincide with my experience.

  13. Jason P

    Dec 13 Xojo Inc Texas
    Edited 6 weeks ago

    It would be nice if you could describe the tasks in the IDE you're seeing that are slow. And what your IDE has open at the time. Are you showing search results? Are you showing all breakpoints or bookmarks?

    The more detail you can give us the more likely it is we can isolate some specific causes. "The IDE is slow" isn't detailed enough to know what to even go looking for.

    We do know that there are some specific things, like groupboxes in dark mode, that we are looking into. At this time it's unclear what we can do as this specific issue also affects Xcode in dark mode.

  14. Dave S

    Dec 13 San Diego, California USA

    For me.... its my Tadpole project.... macOS Mojave/Xojo2018r4 and just clicking on a control it now takes up to 5 seconds before the IDE shows it as selected. There is 25 windows, dozens of custom controls (treeview, special buttons, etc.)

  15. Darren R

    Dec 13 Pre-Release Testers, Xojo Pro

    Similar for me. Not a lot of windows but it's a tabbed interface with subtabs on several pages. Project size is only ~15MB but there are many, many controls. Several control arrays (labels). Clicking on a control takes averages 5+ sec before it becomes active. Adding a control takes 5+ seconds. Moving a control is hard because there is so much lag I have to use the cursor keys to get it into the final position. No dark mode; very few groupboxes. The delay when loading the project in r4 is far longer than previous releases - takes so long I initially thought it may have hung - ~65 seconds.

  16. Ralph A

    Dec 13 Santa Monica, California

    Are all people here with the speed issue testing only Desktop projects? Though I can't imagine that makes a difference.

  17. 3 weeks ago

    Julian S

    Jan 4 Pre-Release Testers, Xojo Pro UK
    Edited 3 weeks ago

    If anyone sees this happen again, do me a favour and just check if you have Breakpoints or Bookmarks currently visible in the bottom nav. If you do, try closing the bottom nav by clicking the magnifying glass at the bottom in the middle and see if that instantly speeds up your typing. It just did here, totally related to Feedback Case #54507 but its been changed to a feature request so /shrug

    https://www.dropbox.com/s/er96dwsv45cch9e/Bug54507.mp4?dl=0

  18. Joost R

    Jan 4 Pre-Release Testers, Xojo Pro The Netherlands

    @Julian S If anyone sees this happen again, do me a favour and just check if you have Breakpoints or Bookmarks currently visible in the bottom nav. If you do, try closing the bottom nav by clicking the magnifying glass at the bottom in the middle and see if that instantly speeds up your typing. It just did here, totally related to Feedback Case #54507 but its been changed to a feature request so /shrug

    Yes, I am aware of this quite some time already. (Win10) Having the bottom pane open with items in it, especially the Find-pane, slows down everything. I keep it shut while typing code.

  19. Lee B

    Jan 4 Pre-Release Testers, Xojo Pro

    Groupboxes seem to be a major problem for me

  20. Emile S

    Jan 4 Europe (France, Strasbourg)

    @Joost R I keep it shut while typing code.

    Check it, but I think there is a preference to keep it closed… in Xojo 2018r4. (I do not found the RN entry).

    Check in the Preferences: Debugging --> Hide Search / Warning / Message Pane on run and change its settings, eventually.

  21. Newer ›

or Sign Up to reply!