has bothered me for a while - why cant i use the new MySQL Community Plugin

  1. 6 weeks ago

    damon p

    Dec 11 Pre-Release Testers, Xojo Pro

    HI Guys,
    not a big problem but for some reason I cannot get any love from the MySQLCommunityPlugin.xojo_plugin since the 2016 version.

    If I replace the plugin which comes with 2018r4 with the one from 2016 I can connect to my "MySQL Community server (GPL)" perfectly.

    Server is 5.7.24

    If I don't replace it and try it will connect to the database fine but when i do a select I get the error
    "Lost connection to MySQL server during query"

    This is using the same program, same username and password, same database, the only difference is the plugin.

    Any ideas?

    thanks

    Damon

  2. Alberto D

    Dec 11 Pre-Release Testers, Xojo Pro

    If you could help create a sample project then the team could fix this. As far as I can tell, as of today, they can't reproduce the problem.

    See Feedback Case #51838

  3. damon p

    Dec 11 Pre-Release Testers, Xojo Pro

    would love to but feedback hasnt worked for ages.
    When run it doesnt connect to the server.
    I even just downloaded the most recent feedback for windows with the same error

    -image-

    Any ideas?

  4. Alberto D

    Dec 11 Pre-Release Testers, Xojo Pro

    I'm sorry you can't connect to Feedback server. I don't have that problem with my mac or windows laptops.

    Are you using windows? Maybe a firewall restriction?

    If you can create a sample code, maybe connection to a test account to your server, I could try to reproduce the issue and update or create a new feedback case for you.

  5. Christian S

    Dec 12 Pre-Release Testers, Xojo Pro, XDC Speakers Germany

    You can always use MBS Xojo SQL Plugin as an alternative.

  6. Jason P

    Dec 12 Xojo Inc Texas

    @damon p HI Guys,
    not a big problem but for some reason I cannot get any love from the MySQLCommunityPlugin.xojo_plugin since the 2016 version.

    If I replace the plugin which comes with 2018r4 with the one from 2016 I can connect to my "MySQL Community server (GPL)" perfectly.

    Server is 5.7.24

    If I don't replace it and try it will connect to the database fine but when i do a select I get the error
    "Lost connection to MySQL server during query"

    This is using the same program, same username and password, same database, the only difference is the plugin.

    Any ideas?

    thanks

    Damon

    We actually use the MySQL plugin from the most recent releases for some internal processes so it's hard to diagnose what might be different in your usage.

  7. Isaac R

    Dec 12 Pre-Release Testers, Xojo Pro Minnesota, USA

    Related: I've been trying to compile the community plugin from source and can't get that to work. Would really like to be able to use this plugin and contribute to it.

  8. damon p

    Dec 12 Pre-Release Testers, Xojo Pro

    Hi Alberto De Poo,
    Yes I am using windows 7
    Do you know what ports need to be opened?
    I created a rule in the firewall to allow Feedback.exe but it didn't make a difference.
    Thanks
    Damon

  9. Alberto D

    Dec 12 Pre-Release Testers, Xojo Pro

    Sorry, I don't know. I remember on my Windows laptop allowed the connection when first ran Feedback but don't know much about changing the firewall settings.

  10. Tanner L

    is not verified Dec 12 Pre-Release Testers Toronto, Canada

    @damon p Do you know what ports need to be opened?

    On my Mac Feedback is using port 443 and it's probably the same on Windows.

    You might double check your firewall to ensure that 443 isn't being monopolized by an errant web browser. Punching a bi-directional hole through for Feedback on 443 should work though.

or Sign Up to reply!