CGI Deploy

  1. last week

    I ask if anyone can help me, because I just can't solve.

    My webapp deployed in CGI mode on Windows 2012 Server works regularly (e.g.: "http://1.2.3.4/cgi-bin/myWebApp/myWebApp.cgi").

    I would like the webapp to run from the home page (e.g.: "www.myhome.xxx" addresses "1.2.3.4/cgi-bin/myWebApp/myWebApp.cgi").

    after so many attempts, I have not yet understood if I should use Redirect, Alias or other instructions.

    and HOW I should use it.

    thank you all

  2. Alberto D

    Dec 4 Pre-Release Testers, Xojo Pro

    One option is to create a Stand Alone web app and run that instead of the web server.

  3. Paul L

    Dec 4 Xojo Inc http://docs.xojo.com

    The Xojo Cloud page has some techniques that should work with most web servers:

    https://docs.xojo.com/UserGuide:Xojo_Cloud_General_Information#Domain_Name_Redirection

    For anything more sophisticated you will have to dig into your web server configuration settings.

  4. thank you Alberto,

    my CGI webapp works fine.

    my only problem is what I've described.

    I have little experience with Apache-CGI and so I'm wasting a lot of time.
    I'm sure someone here knows a lot more than me and I hope they can help me.

  5. Alberto D

    Dec 4 Pre-Release Testers, Xojo Pro

    Are you running Apache on your Windows Server or other server software?

    I'm sure that there is Apache configuration to make the cgi app work as your home page. It all depends on what you want to do:

    • redirect with an index file
    • redirect by default
    • configure your server to make the URL do not change (stay at home page) and execute your cgi app
    • maybe even use an index file with a frame to the cgi app

or Sign Up to reply!