Internal Server Error since 2018

  1. last week

    Alain L

    Oct 10 Québec, Canada

    Since the 2018 release my server is displaying an error.
    I downloaded one of your examples on the server.

    CENTOS 7.5 virtuozzo [serveur1] v74.0.9 Load Averages: 0.14 0.31 0.17

    Do I need to notify my administrator of something to correct?

    Alain

    Yes, probably. I don't have much Linux experience and nothing with CentOS.

    The information I posted was from: https://centos.pkgs.org/7/centos-x86_64/libunwind-1.2-2.el7.x86_64.rpm.html
    It looks like install a package with the following:

    libunwind
    libunwind(x86-64)
    libunwind-coredump.so.0()(64bit)
    libunwind-x86_64.so.8()(64bit)
    libunwind.so.8()(64bit)

    So maybe the last one is what CentOS needs, or maybe is another package called libunwind8 with other libraries (but I can't find information about that).

    Edit: here is more information that can help https://forum.xojo.com/47332-xojo-2018r1-internal-server-error/0

    @Daniel I can confirm that yum install -y libunwind.x86_64 resolved the dependency for me.

  2. Greg O

    Oct 10 Xojo Inc

    Did you install the libunwind8 libraries?

    You can also find out more by running the binary from the command line and then launching it with ldd. For instance, if your app was named MyApplication, you'd run the following 2 lines:

    ./MyApplication
    ldd ./MyApplication

    The output from both of those would be very helpful in tracking this down.

    We may also need to know if you're building CGI or Standalone apps.

  3. Alain L

    Oct 10 Québec, Canada

    NO, i didn't install the libunwind8 libraries.
    I don't know what it is?

    I use CGI

    CENTOS 7.5
    linux

    Alain

  4. Alberto D

    Oct 10 Pre-Release Testers, Xojo Pro

    Xojo 2018 needs libunwind on Linux. I think you can install that on CentOS with:

    # yum install libunwind
  5. Greg O

    Oct 10 Xojo Inc

    @Alberto D;Poo Xojo 2018 needs libunwind on Linux. I think you can install that on CentOS with:
    # yum install libunwind

    It's probably

    yum install libunwind8
  6. Alberto D

    Oct 10 Pre-Release Testers, Xojo Pro Answer
    Edited last week

    Yes, probably. I don't have much Linux experience and nothing with CentOS.

    The information I posted was from: https://centos.pkgs.org/7/centos-x86_64/libunwind-1.2-2.el7.x86_64.rpm.html
    It looks like install a package with the following:

    libunwind
    libunwind(x86-64)
    libunwind-coredump.so.0()(64bit)
    libunwind-x86_64.so.8()(64bit)
    libunwind.so.8()(64bit)

    So maybe the last one is what CentOS needs, or maybe is another package called libunwind8 with other libraries (but I can't find information about that).

    Edit: here is more information that can help https://forum.xojo.com/47332-xojo-2018r1-internal-server-error/0

    @Daniel I can confirm that yum install -y libunwind.x86_64 resolved the dependency for me.

  7. Alain L

    Oct 11 Québec, Canada

    Merci!

    Every look good.
    Resolved

    Alain

or Sign Up to reply!