Disabled StyledText on TextArea

  1. 8 months ago

    Stephen D

    4 Oct 2018 Pre-Release Testers, Xojo Pro

    Any way to prevent styled text from being pasted into a TextArea (Mac/PC)?

    Override paste somehow?

  2. Under the Inspector, just turn the "Styled" to Off

  3. Stephen D

    4 Oct 2018 Pre-Release Testers, Xojo Pro

    Doesn't turning it off only work on Linux?

  4. @Stephen D Doesn't turning it off only work on Linux?

    It works for MacOS

  5. 7 months ago

    Jens K

    6 Oct 2018 near Cologne, Germany

    The documentation of the Clipboard class has an example for pasting (unstyled?) text from the clipboard. I cannot test it now, but maybe this is what you are looking for.

  6. Emile S

    6 Oct 2018 Europe (France, Strasbourg)

    What about using a TextField (set the Multilines property ON) ?

  7. Stephen D

    9 Oct 2018 Pre-Release Testers, Xojo Pro

    It looks like as @Edwin L said, you can just turn off the property. Turns out the documentation is incorrect.

  8. Paul L

    9 Oct 2018 Xojo Inc http://docs.xojo.com

    You are correct. I've updated the TextArea.Styled and TextArea.StyledText pages.

  9. Stephen D

    10 Oct 2018 Pre-Release Testers, Xojo Pro

    Thanks @Paul L. BTW, is there a preferred way to notify you of suggested documentation changes?

  10. Emile S

    10 Oct 2018 Europe (France, Strasbourg)

    Use the Feedback application.

  11. Paul L

    10 Oct 2018 Xojo Inc http://docs.xojo.com

    @Stephen D BTW, is there a preferred way to notify you of suggested documentation changes?

    For small typos and mistakes that are easily fixed, a forum PM or email is fine, but Feedback is also great as there's no chance something will get missed.

or Sign Up to reply!