Update on Listbox Malforms Korean sometimes

  1. 3 weeks ago

    Arthur G

    Jun 30 Pre-Release Testers
    Edited 3 weeks ago

    The previous conversation is Listbox Malforms Korean sometimes
    There is an image on the page of malformation.
    I ran into a similar problem with a textarea since it also malforms korean text when it is attached to a file name. (Yes that is the only time it happens)
    I noticed something strange about the text encoding property. It didn't update in the debugger properly.
    What I mean for an alternative is you change the selection by returning to variables and then finding the property again.
    If you don't do that manually the property value doesn't change.
    It also starts as USASCII, which is confusing since I thought it is supposed to be UTF8.
    Normally if you have a property it changes it's values in the debugger if you have selected that property.
    For instance, the TextFont value will change if you change its font in the debugger.
    Yes. I am "grasping at straws" but...

    The control is called Textbx.
    I'll list the code and values in comments.

    TextBx.TextFont = DispFont   // this will change in the debugger as this is a string = font name
    TextBx.TextSize = SizeOfFontMin
    Dim tenc As TextEncoding
    tenc = TextBx.Text.Encoding   //encoding is USASCII
    tenc = App.LilWinTextE.Encoding   //encoding is UTF8
    LWinText = App.LilWinTextE   //encoding is UTF8
    TextBx.Text = LWinText    //encoding is USASCII without manual update
    TextBx.Text  = DefineEncoding(TextBx.Text, Encdng)   //encoding is USASCII without manual update
    tenc = TextBx.Text.Encoding   //encoding is USASCII without manual update

    I am not too sure how to explain this otherwise.
    I know this happens if a file's name is in a text file and is in Korean.
    How do I separate out what is happening here with Apple?

  2. last week

    Arthur G

    Jul 11 Pre-Release Testers
    Edited last week

    I sort of solved my problem. I changed the font for the textarea to the system font and it stopped decomposing.

    Suggestions

or Sign Up to reply!