Web-App doesn't start after updating to 2018-R1.1

  1. 3 months ago

    Alexandre C

    May 23 Pre-Release Testers, Xojo Pro Brazil

    Hi everybody!

    My CGI built on version 2017r3 works perfectly.

    on version 2018r1 or 2018r1.1 does not.

    The webpage returned the error message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at webmaster@dev.msidatastore.com.br to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    I'm on a centos 7.2.

    Already installed libunwind (libunwind.x86_64 2:1.2-2.el7) for my CENTOS 7.2 server.

    Same error…

    Follow the suggestion to disable SELINUX, but my server does not have the /etc/selinux/config

    Any help?

  2. brian f

    May 23 Pre-Release Testers, Xojo Pro Chilly California

    Check status of selinux on command line: sestatus

    check the path /etc/sysconfig/selinux

  3. Alexandre C

    May 23 Pre-Release Testers, Xojo Pro Brazil

    sestatus: command not found

    /bin/ls: cannot access /etc/sysconfig/se*: No such file or directory

  4. brian f

    May 23 Pre-Release Testers, Xojo Pro Chilly California

    I just logged into my Centos 7.4 server and checked and

    sestatus: disabled

    cd /etc/sysconfig/selinux (config file is there)

  5. Ralph A

    May 23 Santa Monica, California

    Silly question: Are you sure the old web app wasn't running when you uploaded the new CGI file?

  6. Derk J

    May 23 Pre-Release Testers, Xojo Pro
    Edited 3 months ago

    you need libunwind8 (i don't see you say "8")..

  7. brian f

    May 23 Pre-Release Testers, Xojo Pro Chilly California

    I believe libunwind8 is a debian named package

    RedHat (rpm) it is libunwind.x86_64 2:1.2-2.el7 (or whatever the current rpm is)

  8. Derk J

    May 23 Pre-Release Testers, Xojo Pro

    ok, then he needs to check if all libraries that xojo compiled are executable inside the webserver.
    and they must have been ftp'ed or transferred in binary mode.

  9. brian f

    May 23 Pre-Release Testers, Xojo Pro Chilly California

    Derk,

    I'm with you on double checking all required libraries and also on ftp transfer and permissions

  10. Greg O

    May 23 Xojo Inc Somewhere near Raleigh, NC

    @Alexandre C Already installed libunwind (libunwind.x86_64 2:1.2-2.el7) for my CENTOS 7.2 server.

    Is your web app built as 64-bit? if not, you'll also need the libunwind.i686 package.

  11. May 24 Pre-Release Testers, Xojo Pro

    use ldd to find lost lib.

  12. Alexandre C

    May 24 Pre-Release Testers, Xojo Pro Brazil

    @Ralph A Silly question: Are you sure the old web app wasn't running when you uploaded the new CGI file?

    yes… sure

  13. Alexandre C

    May 24 Pre-Release Testers, Xojo Pro Brazil

    @Greg OLone Is your web app built as 64-bit? if not, you'll also need the libunwind.i686 package.

    64-bit

  14. Alexandre C

    May 24 Pre-Release Testers, Xojo Pro Brazil
  15. May 25 Pre-Release Testers, Xojo Pro
    Edited 3 months ago

    Is there a write permission for the "config.cfg" ?
    www-data:www-data

  16. Alexandre C

    May 25 Pre-Release Testers, Xojo Pro Brazil
  17. Alexandre C

    May 25 Pre-Release Testers, Xojo Pro Brazil
    Edited 3 months ago

    just to be more clear than ever:

    i have the same project built on 2017r3 and 2018r1.1
    the 2017 works fine, the 2018 does not.

    one (2017) is on msidatastore.com.br (port 8081)
    and the other one (2018) on dev.msidatastore.com.br (port 8082)

  18. Alberto D

    May 25 Pre-Release Testers, Xojo Pro

    Can you install the 2017 version also on dev.msidatastore.com.br (port 8082)? Just to make sure everything is working.
    Do you have or can test other server version like CentOS 7.4 or 7.5?
    Can you share your project with someone with access to other version like Ubuntu?
    Can you test locally or use a service like digitalocean or vultr, to test other installations?

    I know this is not ideal, but I think that is hard to find the problem and the more tests you can do the more information you will find.

  19. Greg O

    May 25 Xojo Inc Somewhere near Raleigh, NC

    Out of curiosity, have you tried just running the binary from the command line to see if any other errors are generated?

  20. Alexandre C

    May 25 Pre-Release Testers, Xojo Pro Brazil

    @Alberto D;Poo Can you install the 2017 version also on dev.msidatastore.com.br (port 8082)? Just to make sure everything is working.
    in fact on version 2017, i always have both sites up and running. i develop a new version, upload to dev then my client checks before i upload to production site.

    @Alberto D;Poo Do you have or can test other server version like CentOS 7.4 or 7.5?

    my virtual machine at my mac runs ubuntu 14 server. both versions 2017 and 2018 runs fine.

    @Alberto D;Poo Can you share your project with someone with access to other version like Ubuntu?

    no, i can't. there are sensible information on project

    @Alberto D;Poo Can you test locally or use a service like digitalocean or vultr, to test other installations?

    i test locally on ubuntu

    @Alberto D;Poo I know this is not ideal, but I think that is hard to find the problem and the more tests you can do the more information you will find.

    the big problem here, on my point of view, is that i'm doing the same thing about 3 years, on same project. then only on this particular change, from 2017r3 to 2018r1.1, it just does not work! at all

  21. Newer ›

or Sign Up to reply!