R3 not recognizing MySQL Community server

  1. last week

    Tom D

    Dec 6 Pre-Release Testers, Xojo Pro
    Edited last week

    I made my first attempt at compiling an existing project in the debugger and it fails.

    -image-

    Has something changed or is it possible the R3 build installed a corrupt plugin?

    Problem solved. Apparently The Einhugur e-CryptIt Engine 13.1.5 was corrupt. Installing a new copy fixed the issue. R3 is reinstalled and all plugins are now working correctly

    Bob, I made sure that I had updated MBS to 17.5 and all my Einhugur plugins were the latest versions before installing R3 the first time.

    Thanks for the help everyone!

    Now get back to work. I'll owe you a beer at XDC.

  2. Tim P

    Dec 6 Pre-Release Testers, Xojo Pro
    Edited last week

    -image-

    Edit: Did you update your plugins too? You can't use an old plugins folder for R3 because the newest IDE is 64 bit and requires plugins that are 64bit capable.

  3. Norman P

    Dec 6 Xojo Inc
    Edited last week

    can't see the image so cant tell what it is you're trying to show us

    I can say that the apps I use for Xojo Inc that connect to mysql work fine in R3 with its latest plugins
    That looks like the plugin isn't loaded

  4. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro
    Edited last week

    I get the Message "Can't find a type with this name" highlighting MySQLComunity server in the errors and warnings when I try to run it in the debugger.

    Globals.DBConnect, line 8
    Can't find a type with this name
    MySQLDB = New MySQLCommunityServer
  5. Bob K

    Dec 6 Pre-Release Testers, Xojo Pro Kansas City

    It can't find the plugin. Make sure it's in the plugins folder next to the executable and restart Xojo.

  6. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro

    The plugin is there. It is not being recognized. I have also tried the plugin from 2.1. Still no Joy. I just now decided to drop back to 2.1 and now that is doing the same thing. Grrrr... Let me try a reboot.

  7. Jordan M

    Dec 6 Pre-Release Testers

    I'm also getting the same error on a fresh install of R3

  8. Jordan M

    Dec 6 Pre-Release Testers

    I created Feedback case #50719 for this issue

  9. Travis H

    Dec 6 Xojo Inc
    Edited last week

    Also keep in mind that as of 2017r3 the default Xojo directory on Windows is now found under Program Files, not Program Files (x86) on 64-bit Windows systems. I just helped someone who was looking around in the wrong place, so just thought I'd mention it here in case.

  10. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro

    Thanks Travis but I know the default Program location for 64 bit apps is Program Files and not Program Files (x86).

    A reboot did not fix the issue on R3. Time to uninstall R3 and hope R2.1 starts working again.

  11. Jordan M

    Dec 6 Pre-Release Testers

    I can also confirm what Tom said I have rebooted still does not work, the plug-in is in the folder with the other plug-ins that installed with the application. In the "Program Files" directory. Its almost like the plug-in is not getting loaded, does not even show up as you start typing for autocomplete.

  12. I had the same problem with the Valentina plugin on Windows 10 64 bit. I contacted them and they told me they work ... Can it be a problem only for some installations of the R3 version?

  13. Alberto D

    Dec 6 Pre-Release Testers, Xojo Pro

    Is this only on Windows installations?

  14. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro
    Edited last week

    I removed R3 and R2.1 still has this new behavior. I rebooted and reinstalled R2.1. Again, Still no Joy. I'm basically dead in the water since most of my development is based around web apps and MySQL Server.

  15. Paul L

    Dec 6 Xojo Inc http://developer.xojo.com

    I just tried 2017r3 on Windows 10 and I do not get a compile error with this code:

    Dim db As New MySQLCommunityServer

    Are you absolutely sure the plugin is loaded? You can check by going to About Xojo and clicking the "Loaded Plugins" tab.

    And make sure you are using the MySQLCommunityPlugin from r3 and not a plugin from an older version.

  16. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro

    Albert De Poo. I'm on Windows 7 so it's definitely happening on the Windows platform. I haven't fired up my Mac and installed R3 on it yet. I'll let someone that has verify if the problem exists there too.

    I'm considering uninstalling all versions of Xojo and trying a clean install of 2.1. The fact that it occurred on R2.1 only after installing R3 leads me to believe R3 made some systemic change either in in the registry.

  17. Try cleaning out all the files from the AppData folder Xojo is creating for itself.

  18. Paul L

    Dec 6 Xojo Inc http://developer.xojo.com

    I also just tried Windows 7 but I still do not get a compile error with this code:

    Dim db As New MySQLCommunityServer
  19. Tom D

    Dec 6 Pre-Release Testers, Xojo Pro

    Paul I've always created a Public Property MySQLDB as MySQLCommunityServer and up until I installed R3 and attempted to use it today I've never had a problem with that. I have dozens of apps with that method.

    I'm encountering the error in my connection Methods and the debugger says that it Can't find a type with this name
    MySQLDB = New MySQLCommunityServer highlighting MySQLCommunityServer

    Public Function DBConnect(DBName As String) as Boolean
      // creates new database instance
      // and connects to it, noting any problems
      // and giving the operator a chance to reconnect
      
      Dim connected As Boolean
      
      Do
        MySQLDB = New MySQLCommunityServer
        MySQLDB.Port = DBPort
        MySQLDB.DatabaseName = DBName
        MySQLDB.Host = MySQLDBHost
        MySQLDB.UserName = MySQLDBLoginID
        MySQLDB.Password = MySQLDBPassword
        
        connected = MySQLDB.Connect()
        
        If connected =  False Then
          Dim desc,err As String
          desc = "Globals.DBConnect.DBName.Database Error"
          err = ", Cannot Contect to Database  " + Str(MySQLDB.ErrorCode) + " - " + MySQLDB.ErrorMessage
          // Log the Exception
          LogExceptions(desc + err)
          // Send a Notification Email
          SendEmail(desc + err,"StatusWebService." + desc,"text")
          Return False
        Else
          Return True
        End If
      Loop until connected 
      
    End Function
    
    
    Public Function DBConnect(host As String, name As String, loginID As String, password As String) as Boolean
      // creates new database instance
      // and connects to it, noting any problems
      // and giving the operator a chance to reconnect
      // NOTE gets connect info from Preferences Window fields directly
      
      Dim connected As Boolean
      
      Do
        MySQLDB = New MySQLCommunityServer
        MySQLDB.Port =DBPort
        MySQLDB.DatabaseName = name
        MySQLDB.Host = host
        MySQLDB.UserName = loginID
        MySQLDB.Password = password
        
        connected = MySQLDB.Connect()
        
        If connected =  False Then
          Dim desc,err As String
          desc = "Globals.DBConnect.List.Database Error"
          err = ", Cannot Contect to Database  " + Str(MySQLDB.ErrorCode) + " - " + MySQLDB.ErrorMessage
          // Log the Exception
          LogExceptions(desc + err)
          // Send a Notification Email
          SendEmail(desc + err,"StatusWebService." + desc,"text")
        Else
          Return(True)
        End If
      Loop until connected 
      
    End Function
  20. Paul L

    Dec 6 Xojo Inc http://developer.xojo.com

    @Tom D Paul I've always created a Public Property MySQLDB as MySQLCommunityServer and up until I installed R3 and attempted to use it today I've never had a problem with that. I have dozens of apps with that method.

    That method works fine and continues to work fine for me having just again tried it with Windows 10. Have you verified the plugin is loaded by going to About Xojo and clicking "Loaded Plugins"?

  21. Newer ›

or Sign Up to reply!