Build After Update To 2017 Release 3

  1. 11 months ago

    After update to Release 3, I can't do a build unless I delete the previous build - get file system error #105.

    Have been away from xojo for a while, but can now report that my original build problem in early December has been solved. I can now build repeatedly without having to delete the previous build file. I assume this is due to the update to Mac OS 10.13.2 as nothing else has changed. Thanks to all who made suggestions to solve this problem.

  2. Running on Mac OS 10.13.1 Build 17B1003

  3. I can't get 10.13.2 - is yours a beta?

  4. Could it be that the bug is confined to 10.13.1?

  5. scott b

    5 Dec 2017 Pre-Release Testers, Xojo Pro local coffee shop

    at the office we have seen with our clients a lot of odd little bugs with 10.13 both 10.13.0 and 10.13.1. To the point they are starting to restrict their developers to not use the 10.13 betas except for a 100% (spare) test machine. not even for their developer’s laptop.

    all the people I support run 10.12 or below. Except one fool that “has to have” 10.13, none of them run it. that one person has issues all the freakin time. I don’t think 10.13 is ready for prime time.

  6. Scott C

    5 Dec 2017 Pre-Release Testers, Xojo Pro Nova Scotia, Canada
    Edited 11 months ago

    I ran across the #105 error recently myself, using 2017 R2.1 on macOS 10.12.6.

    #105 error in iOS

    I wasn't able to reproduce it reliably, so I didn't file a Feedback report. But after my little fix, it went away (including the temp folder).

    I hope that helps. Good luck.

    Edited: typo on the error number.

  7. I have discovered that release 2.1 also has this problem on my machine. I am suspicious that this problem may be due to the update to to High Sierra 10.13. I had not done any builds for some time, but I think everything worked OK on 10.12.

  8. Richard W

    6 Dec 2017 Pre-Release Testers, Xojo Pro

    Same problem here using 10.13.2 beta 6. I would tend to agree that 10.13.x is still not ready for prime time.
    I finally added a build script that removes the previous build.

  9. I think what we discovered is that the OS is holding onto the icon file and marks the bundle as “in-use” which caused this behavior. Also thought we’d fixed it in r3 but apparently not for everyone. :(

  10. Sascha S

    6 Dec 2017 Pre-Release Testers, Xojo Pro Germany/W'haven

    Does it help to add the Folder in which you create the Build/Debug App, to the Folders ignored by Spotlight?

    I think it's in: System Settings > Spotlight > Privacy

  11. 10 months ago

    I have found that if I delete the Build file before entering a project (with the exception of one project), I can build multiple times with no error and subsequent opening of these projects (without deleting the Build file) also build with no error. There is one project that I have to delete the existing build before I can build without error and then subsequent Build attempts all have the Build error. There must be something about this project that produces the error but I can’t find what it is. if I find the problem I will post it here.

  12. Check and see if they all have icons.

  13. Greg, I think you have hit on something here. If I delete the icon for the troublesome app, I can build successfully without having to delete the previous build file. The question now is how do I build apps with an icon? Thanks so much for this info, I was trying many things without success until your suggestion.

  14. Beatrix W

    9 Dec 2017 Pre-Release Testers Europe (Germany)

    That the icon is the problem isn't exactly new. I think someone either on the forum or in the Feedback case tried to add the icon after building and ran into different problems.

  15. Greg, I am sorry I missed your earlier post about the icon problem. Also, I updated my Mac to 10.13.2 this morning and it did not solve the build problem. I don't see others complaining about the icon problem - does this mean that it is something unique to my Mac.

    Beatrix, I did not do any builds for quite some time so I just noticed the problem after the Release 3 update.

  16. Norman P

    9 Dec 2017 Xojo Inc North of 50

    when you see this occur run

    lsof +D <drag the troublesome debug build into terminal so you get the right path>

    I'm VERY curious about the output as we do a very low level unlink to remove these files
    Unlink is what RM calls to remove files
    That they persist is VERY surprising

    I've seen Quicklook and LaunchServices holding onto fileslong enough that we do not successfully remove the entire debug build

  17. Norman, thanks for your input, but I am not comfortable doing Terminal stuff. I would prefer to wait for a XOJO fix if one can be found.

  18. Newer ›

or Sign Up to reply!