Can't Build iOS App

  1. 8 weeks ago

    James R

    Sep 21 Pre-Release Testers, Xojo Pro Connecticut
    Edited 8 weeks ago


    I am trying to build an iOS app on another machine while I'm traveling and I get the following error when I build it:

    The operation couldn’t be completed. 9650210D0D983DF120D059B9ED41FCEC66F45384: no identity found

    I can run the app on the simulator, but can't build it for the device. I'm using Xojo 2015 Release 2.1 with Xcode 8.2.1

    I think all the Provisioning Profiles are present. I just don't know what is going on.

    Any help would be greatly appreciated.

    I think it has to do with Code Signing. It will build with TEAM set to None, but not with my profile selected.


  2. last week

    Hi James
    I'm getting same error. Did you get solution for this problem?

  3. 6 days ago

    Jérémie L

    Nov 11 Pre-Release Testers, Xojo Pro Europe (France)
    Edited 6 days ago

    This might help:

    • Quit Xojo
    • Open Xcode, go to Preferences > Accounts tab
    • Make sure you are still logged into your account, if not log back in
    • Click on Download all profiles button
    • Open Xojo
    • Try building again using your team.
  4. 3 days ago

    I tried the steps you mentioned but it still gives same error.
    I have XOJO 2017 release 1 and Xcode 8.2.1 as well as 9.1
    Is Xcode version causing this problem?

  5. Paul L

    Nov 14 Xojo Inc

    Xojo 2017 Release 1 is compatible with Xcode 8, but not Xcode 9. If you are using Xcode 9 you will have to make sure you run Xcode 8 last and that its Preferences point to the Xcode 8 command line tools.

    Even after doing this you may find that you have to revoke and recreate all your certificates and related information in both Xcode and iTunes Connect.

  6. yesterday

    Is Xojo 2017 Release 2.1 compatible with Xcode 9?
    Should the Xcode account be logged in ?
    If yes then, why is that if one xcode9 logged in then xcode 8 is logged out.?
    Xcode keeps logging out.

  7. Art G

    yesterday Prescott AZ

    @devyani g Is Xojo 2017 Release 2.1 compatible with Xcode 9?


or Sign Up to reply!