Kaju self-updater talk (v.2.x)

  1. ‹ Older
  2. 2 years ago

    Julia T

    4 Nov 2018 Sandy Hook, Connecticut

    Trying Kaju seriously for the first time now, and unclear on a few points. Firstly, is this a reasonable server directory structure?

    -image-

    Secondly, I'm confused as to the sequence of events: I have to first load my binaries into the Admin app in order to get an RSA key, but the RSA key has to go back into the Xojo source and then I need to recompile with the RSA key and upload again? Won't that change the hash values?

    Am I supposed to do anything with the hash values?

    When there's an update, exactly what needs to be changed in the Xojo source? Do I need to generate and compile with a new RSA key for each release? I'm guessing yes, since the updater URL always points to the same JASON file.

    When I try the Preview pulldown in the Admin app, I get this "Missing security token" error:

    -image-

    This is after compiling with the RSA key in the Xojo source and re-uploading the files. Despite getting this error on preview, Kaju still exported an updater file, but I haven't tested it yet.

  3. Kem T

    4 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    No, once you create the admin file (which you should save in a safe place), you can get the RSA key from it and that key doesn't not change. Put the key into your app as illustrated by the test project and described in the Read Me and then compile. All the Update info needs is to know the hash of the zip file associated with each version.

    I don't know why it would be giving you that error in Preview.

  4. Julia T

    4 Nov 2018 Sandy Hook, Connecticut

    Updater's working now, and I'm starting to get the hang of it, thanks :)

  5. Hi Kem,

    First let me say I love Kaju and for the most part it works great, except for one thing...

    I am using v2.1 and I have the same issue as Julia Truchsess above, where which ever option I choose in the Preview pulldown in the Admin App, I always get the "Missing security token" error. It's probably something I'm doing wrong although I've been through the documentation and I can't see what might be missing. I am on MacOS 10.14 Mojave, incase you think that might be the cause?

    Thanks

  6. Kem T

    7 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    Unfortunately, I am not on Mojave so I can't test that aspect of it, and I don't know why Preview would be doing that. Perhaps @Julia T figured that out?

  7. Hmmm, I wonder, could it be because my files are not being accessed via https?

    I see that is also the case with @Julia T in her screenshot above...

    Thanks

  8. Kem T

    7 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    I haven't merged the develop branch into master yet, but you should try that out with the new ExecuteAsync function. That uses the new framework HTTP socket and might resolve all sorts of problems.

  9. OK Kem, thanks for your reply, I'll give it a go and let you know... :)

  10. Sorry Kem I can't work out how to use the Async socket...

    Here's a screenshot of the error I see in the IDE (in case this helps).

    -image-

    Thanks

  11. Alberto D

    7 Nov 2018 Testers, Xojo Pro Austin, Texas

    Image:
    -image-

  12. Kem T

    7 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    Thanks Alberto, that might clear it up. That might be a bug where you need to copy the public key once just to get it to generate before using Preview.

  13. Julia T

    7 Nov 2018 Sandy Hook, Connecticut

    HIgh Sierra here, not Mojave. I resolved the issue by ignoring it, since the updater works :)

  14. Mark S

    16 Nov 2018 Testers, Xojo Pro

    I am trying to implement Tem's version of Kaju for a Windows app. I am using the latest 2.x from Github. I am using High Sierra to compile with Xojo 2018 release 2.

    Cannot get past this error:
    "The update packet signature marker was incorrect"

    I put the output of the Xojo compile in the root of a ZIP file and not the directory for the app created by the compiler.

    I assume Julia's directory structure is correct above and the JSON file goes in the top level and various versions can go in sub-directories as her screen shot above. I am putting the correct URL in the Windows program on where to find the ZIP file in one of the sub-directories but how does Kaju know where to find the JSON file?

    I think I am finding the ZIP file OK because if I rename it on the server to a "bad" name I get a fairly quick error but if the name is correct it takes a while for the error to appear.

    I can get the admin program to calculate the hash from the URL although I have a cert on the server the admin program won't recognize the URL as an httpS.

    Is this error based on the hash or "security token" in the JSON file?

    Any help would be appreciated.

    I am getting close to just putting a way to download an InnoSetup installer but some time in the future I may also have a Mac version.

  15. Julia T

    16 Nov 2018 Sandy Hook, Connecticut

    @Mark S I am putting the correct URL in the Windows program on where to find the ZIP file in one of the sub-directories but how does Kaju know where to find the JSON file?

    The URL must point to the JSON file, not your zipped app.

  16. Kem T

    16 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    What she said.

    Mark, have you gone through the READ ME and tried the test app that comes with the project?

  17. Julia T

    16 Nov 2018 Sandy Hook, Connecticut
    Edited 2 years ago

    The ReadMe, despite having a seemingly great amount of detail and even a section called "Step by Step", nonetheless presumes a lot of pre-knowledge about how Kaju works on the part of the user. In this case, the info on that URL says only "you must also set... the UpdateURL where it will get its update information", which is pretty ambiguous.

  18. Mark S

    16 Nov 2018 Testers, Xojo Pro

    I have actually printed the ReadMe and looked at it carefully but as Julia says I think it assumes some knowledge of Kaju. Before I saw this post I did not have any version sub-directories but when I saw Julia's structure it was clear I did not fully understand everything I needed to know.

    I have experimented for a while before posting here. Hopefully this will get me past the "signature marker" error.

    Thanks.

  19. Kem T

    16 Nov 2018 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    I'll take a look at that for the next release, thanks.

  20. Mark S

    16 Nov 2018 Testers, Xojo Pro

    Good progress but a few more issues. One cosmetic and one fatal.

    After sorting out the URL and a few other issues I am now presented with the Update Available window when I request the update.

    There is a label near the top that says:
    "You have version 1.1. Would you like to install version 1.2.0?

    My running version is 1.1.0 but the "bug version" portion (third number from the left) is missing. I assume that the trailing dot is a period for the sentence. I think I see maybe why this happens in the Kaju code that creates the display version but I don't want to fix it if there is going to be a new release anytime soon. I have NOT tried it with something other than zero for the "bug version".

    ALSO

    I got to the point of downloading the ZIP and Clicking INSTALL. All seemed to go OK until it tried to relaunch the EXE and it was not found. There was an open CMD window but nothing in it. When I closed the message box the CMD window closed. I searched the computer and the EXE file is NOT on the machine BUT it is in the ZIP file when I manually download it and look.

    I looked at the Update Log file and there were no errors.

    I tried a couple of times and managed to catch a Windows dialog box that I think was the decompressing of the ZIP with a down arrow to show the details. I clicked the downarrow and I thought I saw the EXE file name briefly appear but no errors then the dialog closed.

    On one of the test, but before clicking the "Quit and Install" button, I looked and the new EXE was found in a folder called "<mypath>- decompressed". That directory appeared to be the whole structure with all of the supporting files.

    After the failure message all of the supporting files are installed EXCEPT the EXE file is missing.

  21. last year

    For I have no idea what reason Kaju stopped working today, I always use the same updater app, same files same workflow. I build one version on Xojo2018R3 I pushed the update, worked well. then today I had to push another update , so like 1 week interval, same things same steps , the app does not work anymore .

    For the first debugging it seems that the app gets downloaded on the Temp folder, then it restarts but it stop on replacing the app with the new version. If I open the app from the temp folder it works well and no errors so somehow the copy script or whatever was there stopped working .

    any idea on this ?

    Thanks.

  22. Newer ›

or Sign Up to reply!