Kaju self-updater talk (v.2.x)

  1. ‹ Older
  2. 3 years ago

    Kyryl P

    19 Oct 2017 Xojo Pro Europe (Ukraine)

    Hi Kem,

    Kaju 2.0 doesn't support mac x64 bit?

    Or am I missing something?

  3. Jon O

    19 Oct 2017 Testers, Xojo Pro Chicago Area USA

    @Kyryl P Hi Kem,

    Kaju 2.0 doesn't support mac x64 bit?

    Or am I missing something?

    It does. I use it in 64 bit. What gives you the impression that 64 bit isn’t supported?

  4. Kyryl P

    19 Oct 2017 Xojo Pro Europe (Ukraine)

    http://take.ms/ktky0

    There is no 64bit binary for macos, the same in the code. I can't find it.

    We have 2 version - 32 and 64 bit builds.
    is it possible to use Kaju to update 32bit and 64bit macos apps? Upgrade from 32bit to 64bit Macos?

  5. Jon O

    19 Oct 2017 Testers, Xojo Pro Chicago Area USA
    Edited 3 years ago

    What do you mean no 64 bit binary? Compile it yourself in 64 bit.

  6. Kyryl P

    19 Oct 2017 Xojo Pro Europe (Ukraine)

    sorry, I wasn't clear.

    I mean to update macos 64bit app. There is no option to add 64bit macos binary to the Kaju Admin. Only Linux and Windows.

  7. Jon O

    19 Oct 2017 Testers, Xojo Pro Chicago Area USA
    Edited 3 years ago

    For MacOS everything needs to be 64 bit or just 32 bit basically. There is no reason to compile both 64 bit and 32 bit for MacOS as all current MacOS system builds are 64 bit unlike Windows or Linux.

    If you do 64 bit builds for MacOS don’t do a 32 bit build. It’s redundant.

    Just put the 64 bit build in the location in Kaju admin for the binaries.

  8. Kem T

    19 Oct 2017 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    What Jon said.

  9. Kem T

    19 Oct 2017 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    If you truly do need to compile a separate 32-bit Mac version, use a second admin file that outputs a different json file and have the 32-bit version point to that instead.

  10. Kyryl P

    19 Oct 2017 Xojo Pro Europe (Ukraine)

    Thank you!

  11. Hello Kem,

    Any idea why I`m getting an 103 error ? I get the pref file and the update popup shows but when I press update to do the actual update , it gets stuck for a while then I get this error.

    Thanks.

  12. @Aurelian N Hello Kem,

    Any idea why I`m getting an 103 error ? I get the pref file and the update popup shows but when I press update to do the actual update , it gets stuck for a while then I get this error.

    Thanks.

    Well that was weird, I just copied the URL and paste it on that pc browser, the app start to download, I cancel it and tried again and it started the update , so I have no idea why and how but it start to work now .

  13. It seems that I`m getting some weird thing going on, so first of all , the app does not restart anymore once you press install and quit, then in the updates temp folder I get a folder called appname.exe-1 and one more called a--name.exe-tempfolder , those should be deleted or why there are 2 ? thanks

  14. Kem T

    13 Nov 2017 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    Do you set the App.UpdateInitiater property to Nil in App.Close?

  15. @Kem T Do you set the App.UpdateInitiater property to Nil in App.Close?

    Hi, yes I did, but I guess its something wrong with the pc settings, corporate provisioning, so even the update does not work some times, it gives that 103, which based on the docs means cannot reach or find the url if I`m right so I have no idea why .

    What about those 2 folders ? I assume that one is for the previous version and one for the temp processing folder .

    Thanks.

  16. Kem T

    13 Nov 2017 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    Yes, one is where the new version is downloaded and the other (if I recall) is for temp processing. You should be able to delete both safely.

  17. Bob K

    6 Dec 2017 Testers, Xojo Pro Kansas City

    Any known issues with 2017 R3?

  18. Kem T

    6 Dec 2017 Testers, Xojo Pro, XDC Speakers, MVP Connecticut

    I haven't tried yet, but wouldn't expect so.

  19. Bob K

    7 Dec 2017 Testers, Xojo Pro Kansas City

    hm...okay. getting some odd results back from the HTTPSocket but I'll dig into it more today if I have the chance.

  20. Bob K

    7 Dec 2017 Testers, Xojo Pro Kansas City

    Even though I've set Redirect to true it's not finding the correct address. A quick test in the Xojo framework shows that it brings it back the file contents as expected. So it appears that the redirect code isn't working as expected. Very odd.

    Man, I love this stuff </s>

  21. Bob K

    7 Dec 2017 Testers, Xojo Pro Kansas City

    Looks like Kaju.HTTPSSocket.GetHeaders isn't working the way it's implemented. Always returns Nil (at least in R3).

  22. Newer ›

or Sign Up to reply!