problem with cookies between apps

  1. 7 months ago

    I have two apps, one running at "http://ms001592indfw0001.serverwarp.com/cgi-bin/fhma/fhma.cgi" and one running as a service in another directory on the same server; example: "http://ms001592indfw0001.serverwarp.com/cgi-bin/filter/filterservice.cgi/special/filterservice?netflixid=60002360"

    I'm trying to get the service to read a cookie saved by the other app. In the first app, I'm saving the cookie with session.Cookies.Set("familymoviefilters_prefs",tmpstring,tmpdate ) 'tmpdate is way in the future

    In the service app, in the session open event, I'm trying to read it with
    dim tmpstring as string =session.cookies.value("familymoviefilters_prefs")

    When I run both apps locally, the service app does read the cookie properly. When I run both apps on the remote server, the cookie value is always blank. Am I doing something wrong in how I'm writing or reading the cookie?

  2. Andrew L

    20 Mar 2017 San Francisco, CA, USA

    When the cookie is sent by the remote server, does it specify the "path" parameter?

    e.g. this would prevent a browser from sending the cookie to the service:

    Set-Cookie: familymoviefilters_prefs=foobar; Path=/cgi-bin/fhma/
  3. It turns out this isn't so much of a cookie problem as a session problem. When I run this from the IDE, it works fine because there is an actual session available. When it runs from the remote server, there is no session. I think I'm going to be able to use the webrequest.getcookie function to get the cookie, though I haven't tried it yet.

    Kevin Clark

or Sign Up to reply!