A distribution profile is required when building for the app store

  1. last week

    When I try to build I get this error see screenshot

    https://cl.ly/0z0d1T443L0h

    but both of my distrib and dev certificate are in xcode see screenshot here

    https://cl.ly/2S233f41063i

    I have no idea what to do tks for the help !

  2. 7 days ago

    Art G

    Feb 17 Prescott AZ

    If you're building for iOS I've found that specific app provisioning profiles don't work. Use a generic wildcard profile instead. "*"

  3. Paul L

    Feb 17 Xojo Inc http://developer.xojo.com

    Some troubleshooting suggestions are here:

  4. 6 days ago

    Hello Paul,

    I followed the above steps using a wildcard profile and this time I was able to build and test it on my Iphone which I could't do before but, so no error on build but as soon as I turn on build for the app store I get the same error:

    A distribution profile is required when building for the app store.

    I have tried so many things I dont know what it could be !!

    all my cert appear correctly in Xcode I dont get it
    tks for the help

  5. Michel B

    Feb 17 Pre-Release Testers, Xojo Pro

    FWIW I never was able to use a wildcard.

  6. 5 days ago

    Paul L

    Feb 18 Xojo Inc http://developer.xojo.com

    @serge r A distribution profile is required when building for the app store.

    Unfortunately there is no quick solution that I know of. StackOverflow has many, many posts on this exact issue for people also using Xcode. It is frustrating, but only Apple can make the process better.

    Sometimes the only thing you can do is revoke and remove everything and start again.

or Sign Up to reply!