Flicker in second user

  1. last year

    James P

    11 Jul 2016 Pre-Release Testers, Xojo Pro Jamaica

    My app works fine in the main user of my Mac. However when I open it in another user on the same mac, I get flicker (flickering square patterns) inside any container controls that get moved or scrolled. The size/shape of the squares doesn't seem to correspond to any underlying controls or containers that I'm aware of.

    The problem didn't occur previously but I am now noticing it in OSX10.11.5 with Xojo 2016 r1.1.

    Can anyone think what might cause this?

  2. Michael D

    11 Jul 2016 Pre-Release Testers, Xojo Pro

    James, are both users logged in simultaneously, and is the app running in both?

  3. James P

    11 Jul 2016 Pre-Release Testers, Xojo Pro Jamaica

    Michael,
    Yes, both logged in simultaneously, but get flicker even if the app is only running in the second user.
    Jim

  4. James P

    12 Jul 2016 Pre-Release Testers, Xojo Pro Jamaica

    You can actually download the app on the Mac App store and see the problem.

    Add a new project and add about a dozen line items (name + return for each item). Then try scrolling and see the flicker.

  5. Michel B

    12 Jul 2016 Pre-Release Testers, Xojo Pro

    Maybe that calls for a bug report. It may affect other apps as well.

  6. Michael D

    12 Jul 2016 Pre-Release Testers, Xojo Pro

    @Michel B Maybe that calls for a bug report. It may affect other apps as well.

    Yeah, and maybe a bug report to Apple itself - that seems like an OS level or driver bug, not the fault of Xojo.

  7. Michel B

    12 Jul 2016 Pre-Release Testers, Xojo Pro

    @Michael D Yeah, and maybe a bug report to Apple itself - that seems like an OS level or driver bug, not the fault of Xojo.

    I believe when Xojo finds a system level bug they file a bug report with Apple.

  8. Greg O

    13 Jul 2016 Xojo Inc Somewhere near Raleigh, NC

    @Michel B I believe when Xojo finds a system level bug they file a bug report with Apple.

    We might if it affected all of our users and we could reproduce it.

  9. Marco H

    17 Jul 2016 Pre-Release Testers Cali, Colombia

    I ran into the same issue today and I remembered this thread. Just wanted to report.

    Maybe others could try to create a test user and run a Xojo App that has a repainting Canvas?

    I know my App would flicker on Windows because of some stacked canvasses but the flicker is really bad. Never saw it on OS X before. It's like things are being repainted really slow or something.

    Compared to the 'main' user, the black (shadow?) is also showing way more often before the Window displays. But the main issue is that things are flickering like crazy. White blocks everywhere when repainting the canvas.

    I'm on El Capitan (10.11.5) with 2016R2.

    It doesn't matter if the same App is running on both users at the same time or not.
    Even if I create a new Admin user and I logout from the 'main' user, it's still flickering.

    I have no idea if this happened in the past or not because I never tried it before.

  10. Marco H

    17 Jul 2016 Pre-Release Testers Cali, Colombia

    It guess it is related to El Capitan because I'm not seeing it on my MBP that runs on Yosemite.

  11. James P

    28 Jul 2016 Pre-Release Testers, Xojo Pro Jamaica

    Here's a simple app that shows the flicker.
    Run it in a second user and resize the window - you'll see the flicker effect.

  12. Marco H

    28 Jul 2016 Pre-Release Testers Cali, Colombia

    Good example.
    It flickers although I have an App that flickers a lot more (but I think it's because I use timers to update things while downloading).
    Did you file a bug report with this example?

  13. James P

    28 Jul 2016 Pre-Release Testers, Xojo Pro Jamaica
    Edited last year by Paul L

    This is just an example with minor flicker. My main app flickers much much more.

    A bug report filed: Feedback Case #44760]

    Edit (Paul): Fixed feedback link (you do not need the URL tag)

  14. 9 months ago

    James P

    6 Feb 2017 Pre-Release Testers, Xojo Pro Jamaica

    I have just noticed a variation in behaviour that I thought I would raise in case it triggers any ideas on this forum for fixing this.

    As a reminder, the problem is that my app flickers when in a second user on the Mac whilst repositioning or scrolling container controls.

    Opening multiple windows(B) of the same type within the same app, continues to show flicker across all windows. But when I open a different type of window(C), still within the same app, the flicker stops. And does not reappear when I close the window(C). Note that closing the window also removes it from the app by setting the referring property to nil.

    Window(C) is a developer window, it tracks method calls within the app, and so is being continually updated by adding more lines to listboxes and therefore slows down the app a tad. Somehow its presence, or even the fact that it was there once, stops the flicker elsewhere.

    Closing and restarting the app brings back flicker again.

  15. 2 weeks ago

    James P

    Oct 11 Pre-Release Testers, Xojo Pro Jamaica

    Good news, compiling in 64bit seems to stop this flicker behaviour on Mac 2nd user.

or Sign Up to reply!