CGI App stops running : unable to connect using port...

  1. 4 years ago

    Roger S

    21 Oct 2015 Pre-Release Testers, Xojo Pro

    Hi everyone,

    I'm sorry to start a new conversation on this topic. I looked at many conversations on that same topic but did not find any solutions...

    We have a couple of web applications running in CGI on several servers and they all stop being accessible once in a while without obvious reasons. Everytime, we get the same error : unable to connect using port... Sometimes a simple refreshing of the user browser page will give back access to the app but, we often have to rerstart the application to make it work again.

    We don't affect a specific port (Automatic), it is on an Apache server.

    We have been dealing with that problem for some time now and would be VERY happy to find the cause and the solution to that annoying behavior...

    Thanks in advance...

  2. Greg O

    21 Oct 2015 Xojo Inc scout.galaxy.barn

    One reason this happens is if your web app crashes in the middle of a request or is simply too busy to respond. You may want to periodically check how much ram your app is using with the top command.

    Id also look and see how many simultaneous users you have.

  3. 3 months ago

    natale p

    Sep 15 Pre-Release Testers, Xojo Pro

    I've read several posts on this topic, but I've not read (or I've not seen) a solution (or a clear answer).
    for me, it remains unclear and unresolved .
    does anyone know more?
    has anyone solved it?

    thanks.

  4. Michael D

    Sep 15 Pre-Release Testers, Xojo Pro

    I was having mysterious issues with a WebApp (standalone, not CGI) which seem to be fixed by using 2019R1.1 - what version are you using? See https://forum.xojo.com/conversation/post/454090

  5. natale p

    Sep 15 Pre-Release Testers, Xojo Pro

    thank you Michael,
    I'm using 2019R1.1 with CGI.

  6. Ralph A

    Sep 15 Santa Monica, California

    Does setting AutoQuit=False in App solve this?

  7. natale p

    Sep 15 Pre-Release Testers, Xojo Pro

    thank you Ralph.
    I saw App.AutoQuit = True, now.
    I can change it, to see what happens.
    Why do you suggest to change it?
    How can this setting to solve the problem?

  8. Derk J

    Sep 15 Pre-Release Testers, Xojo Pro

    @natalepappalardo thank you Ralph.
    I saw App.AutoQuit = True, now.
    I can change it, to see what happens.
    Why do you suggest to change it?
    How can this setting to solve the problem?

    This setting should not quit your webapplication if all sessions ended. It will keep the webapplication process running even if there are no sessions alive.

  9. Ralph A

    Sep 15 Santa Monica, California
    Edited 3 months ago

    My experience with Xojo CGI apps is they can become inaccessible often, but only when the user attempts to start up the app after it as been killed by AutoQuit. So I set AutoQuit=False and never saw it happen again. In my case, the inaccessible app would throw an Internal Server Error 500. Those errors are gone now.

  10. natale p

    Sep 15 Pre-Release Testers, Xojo Pro

    thank you all.
    I try it.

  11. Ralph A

    Sep 15 Santa Monica, California

    Of course AutoQuit=False isn't going to help stop these:

    @Greg OLone One reason this happens is if your web app crashes in the middle of a request or is simply too busy to respond. You may want to periodically check how much ram your app is using with the top command.

    Id also look and see how many simultaneous users you have.

or Sign Up to reply!