Can't add CopyFiles Build Step under Windows?

  1. 2 years ago

    Tim J

    21 Jul 2015 Pre-Release Testers, Xojo Pro Phoenix, AZ USA
    Edited 2 years ago by Tim J

    Hi Folks,

    I thought this was resolved, but I just tried adding a Build CopyFiles step to a Windows project under Windows 8.1 and nothing is added. Is this still broken?

    Xojo 15r2.2

    @Tim J Wayne, are you running the IDE under Windows or under OS X? It works fine on OS X, only fails on Windows for me.

    Try right clicking on the navigator, just below your project items and add the build step there you should be able to drag it into the Windows group afterwards.

    Also, check and see if you have a project item or a folder named "Windows". I've seen this cause issues in the past where the build steps end up there instead of where you intended.

  2. Wayne G

    21 Jul 2015 Pre-Release Testers, Xojo Pro New Zealand axisdirect.nz

    Working ok for me. If I select Windows in the navigator under build settings, press the insert button and select build step->CopyFiles the step is added directly to the Windows Build. But if I select the app and follow the same steps the step is added at the bottom of the contents section in the navigator.

  3. Tim J

    21 Jul 2015 Pre-Release Testers, Xojo Pro Phoenix, AZ USA

    Wayne, are you running the IDE under Windows or under OS X? It works fine on OS X, only fails on Windows for me.

  4. Greg O

    21 Jul 2015 Xojo Inc Answer Somewhere near Raleigh, NC

    @Tim J Wayne, are you running the IDE under Windows or under OS X? It works fine on OS X, only fails on Windows for me.

    Try right clicking on the navigator, just below your project items and add the build step there you should be able to drag it into the Windows group afterwards.

    Also, check and see if you have a project item or a folder named "Windows". I've seen this cause issues in the past where the build steps end up there instead of where you intended.

  5. Wayne G

    21 Jul 2015 Pre-Release Testers, Xojo Pro New Zealand axisdirect.nz

    Windows 8.1

  6. Michel B

    22 Jul 2015 Pre-Release Testers, Xojo Pro

    A while ago, I remember encountering that issue. Apparently the project had got corrupted somehow. The way I solved it was to create a new project, then select everything in my corrupted project, copy and paste into the new.

  7. Dale A

    22 Jul 2015 San Diego, California, USA

    A few fast tests seems to indicate that on Windows, unless I have a build platform selected in the Navigator the build step gets added to the top level of the app. If I select a target platform first, the build step gets added to that platform's build settings.

    I don't know if that is the right behavior (behaviour) but it seems logical to me.

  8. Tim J

    28 Jul 2015 Pre-Release Testers, Xojo Pro Phoenix, AZ USA

    Welp, Greg gets the star. It was a folder named Windows into which I place my app's windows. I renamed that folder to Dialogs and things work.

  9. 6 months ago

    I've been having issues with this on and off and could not really get it straight. On some projects it worked, on some others it didn't. I followed the steps outlined by Wayne and Dale, and now it reliably works all the time. Many thanks.

or Sign Up to reply!