MS SQL: API client not set

  1. 3 years ago

    Sascha S

    2 Jan 2015 Pre-Release Testers, Xojo Pro Germany/W'haven

    If my users see the Message "API client not set" on Windows when using MBS, can i simply assume the connection went down?
    Or in other words, i would like to prevent such a Message and replace it with a more informative one (more informative for the normal user, not for myself).

  2. Christian S

    2 Jan 2015 Pre-Release Testers, Xojo Pro Europe (Germany)

    No, it just means you didn't tell plugin for a connection which server type you want.

    What methods do you call?

  3. Christian S

    2 Jan 2015 Pre-Release Testers, Xojo Pro Europe (Germany)

    e.g. with SQLDatabaseMBS, you use con.DatabaseName = "SQLServer:"+server.Text where SQLServer: is the prefix telling the type.
    or with SQLConnectionMBS, you pass it as parameter: con.Connect(server.text,user.text,password.text,SQLConnectionMBS.kSQLServerClient)

  4. Sascha S

    2 Jan 2015 Pre-Release Testers, Xojo Pro Germany/W'haven

    Thank you Christian.
    I have currently no access to my source and will take a look into it at the weekend. I will come back to this Thread if needed, but i think i can fix it with the information you already gave here.

  5. 4 months ago

    Marco

    Apr 20 Micropedia s.r.l. Naples Italy

    i've the same problem i sent you a mail but i've set the connect in the right way.

    If the sql server ip is for example 213.21.36.78 and database name is hello

    server.text should be 213.21.36.78@hello right?

or Sign Up to reply!